Задать вопрос
16 июня, 20:10

Составьте программу определяющую могут ли три числа a, b, c является длинами сторон треугольника

+5
Ответы (1)
  1. 16 июня, 21:58
    0
    Var

    a, b, c:real;

    begin

    Write ('Введите через пробел длины трех сторон: ') ;

    Readln (a, b, c) ;

    if (a+b>c) and (a+c>b) and (b+c>a) then

    Writeln ('Можно составить треугольник')

    else

    Writeln ('Нельзя составить треугольник')

    end.

    Тестовое решение:

    Введите через пробел длины трех сторон: 2 6 9

    Нельзя составить треугольник

    Введите через пробел длины трех сторон: 3 4 5

    Можно составить треугольник
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу определяющую могут ли три числа a, b, c является длинами сторон треугольника ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Составить программу, определяющую, является ли данное утверждение истинным: Двузначное число А начинается на 3 Составить программу, определяющую, является ли данное утверждение истинным: Ровно одно из чисел А и В не превышает 100
Ответы (1)
Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его тип Имеются данные о количестве полных лет трех призеров спартакиады.
Ответы (1)
Информатика: решение задачи на языке Паскаль. Текст задачи: даны три натуральных числа. Напишите программу, определяющую существует ли треугольник с такими длинами сторон.
Ответы (1)