Задать вопрос
31 января, 22:56

Составить программу обмена местами максимума и минимума в массиве

+2
Ответы (2)
  1. 31 января, 23:18
    0
    Var a:array[1 ... 1000] of integer;

    N, max, max1, min, min1, i: integer;

    begin

    writeln ('Введите количество элементов') ; readln (N) ;

    min:=32768; max:=-32768;

    for i:=1 to N do begin

    readln (a[i]) ;

    if a[i]>max then begin max:=a[i]; max1:=i; end;

    if a[i]
    end;

    if (max-32769) and (min32768) then begin

    i:=a[max1]; a[max1]:=min; a[min1]:=i; end

    else writeln ('Обмен невозможен') ;

    readln

    end.
  2. 1 февраля, 01:51
    0
    var a, b, c, i, n, max, min:integer;

    s : array [1 ... 10000] of integer;

    begin

    read (n) ;

    for i:=1 to n do

    read (s[i]) ;

    max:=s[1];

    min:=s[1];

    a:=1;

    b:=1;

    for i:=1 to n do

    begin

    if s[i]>=max then

    begin

    max:=s[i];

    a:=i;

    end;

    if s[i]
    begin

    min:=s[i];

    b:=i;

    end;

    end;

    s[a]:=min;

    s[b]:=max;

    writeln;

    for i:=1 to n do

    write (s[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу обмена местами максимума и минимума в массиве ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу которая в массиве из 10 элементов находят произведение минимума и максимума значимых элементов
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
В заданном массиве A (n) определить среднее арифметическое значение минимума и максимума. Если таких элементов нет, вывести на экран дисплея сообщение "вы ввели не число".
Ответы (1)
Запишите программу циклического обмена значениями трех переменных a, b, c. Схема циклического обмена:a->b->c. Например если до обмена было:a=1, b=2, c=3, то после обмена должно стать:a=3, b=1, c=2. Выполнить трассировку
Ответы (1)
Прошу, помогите написать программу! (Тема - Операции над массивами.) Написать программу, которая в одномерном массиве, заданным вводом данных с клавиатуры находит число положительных чисел в массиве.
Ответы (1)