Задать вопрос
11 марта, 22:26

Составить программу которая в массиве из 10 элементов находят произведение минимума и максимума значимых элементов

+1
Ответы (1)
  1. 12 марта, 01:52
    0
    Type

    mas = array [1 ... 10] of integer;

    var

    x: mas;

    min, max: integer;

    i: integer;

    begin

    for i : = 1 to 10 do

    readln (x[i]) ;

    min : = x[1];

    max : = x[1];

    for i : = 2 to 10 do begin

    if x[i] < min then

    min : = x[i];

    if x[i] > max then

    max : = x[i]

    end;

    writeln (max * min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая в массиве из 10 элементов находят произведение минимума и максимума значимых элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу обмена местами максимума и минимума в массиве
Ответы (2)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
В заданном массиве A (n) определить среднее арифметическое значение минимума и максимума. Если таких элементов нет, вывести на экран дисплея сообщение "вы ввели не число".
Ответы (1)