Задать вопрос
8 июля, 22:16

Дан массив вещественных чисел, содержащий 25 элементов вычислить сумму элементов массива начиная с первого элемента и максимального элемента массива включительно

+5
Ответы (1)
  1. 9 июля, 02:15
    0
    На java, элементы массива вводятся с клавиатуры

    import java. util. Scanner;

    public class qwert {

    public static void main (String args[]) {

    Scanner scn = new Scanner (System. in) ;

    double[] n = new double[25];

    double c = 0;

    for (int i = 0; i < 25; i++) {

    n[i] = scn. nextDouble () ;

    c = c + n[i]; }

    System. out. println (c) ;

    } }

    вот паскаль, тоже через клавиатуру

    var a: array [1 ... 25] of double;

    i : integer;

    b, c : double;

    begin

    for i : = 1 to 25 do

    begin

    readln (a[i]) ;

    c : = c + a[i];

    end;

    write (c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив вещественных чисел, содержащий 25 элементов вычислить сумму элементов массива начиная с первого элемента и максимального ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)