Задать вопрос
5 марта, 20:23

Cоставьте программу заменяющую в заданном тексте все буквосочетания "да" на "нет".

+2
Ответы (1)
  1. 5 марта, 23:12
    0
    Var

    a:longint;

    s:string;

    begin

    read (s) ;

    while pos ('да', s) >0 do

    begin

    a:=pos ('да', s) ;

    delete (s, a, 2) ;

    insert ('нет', s, a)

    end;

    writeln (s)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Cоставьте программу заменяющую в заданном тексте все буквосочетания "да" на "нет". ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
9.65. Дано предложение. Определить: а) число вхождений в него буквосочетания ро; б) число вхождений в него некоторого буквосочетания из двух букв; в) число вхождений в него некоторого буквосочетания.
Ответы (1)
1) Составить программу удаляющую из данного текста все буквосочетания "ма" и выводящую получившийся текст и его длину. 2) Составить программу находящую количество букв "с" в тексте.
Ответы (1)
В заданном тексте заменить все встречающиеся пары из одинаковых цифр, словом 'две'. Введите текст, в котором нет цифр. Какой ответ выдаст программа? Внесите изменения в программу так, чтобы на этот случай выдавалось сообщение 'в тексте нет цифр'
Ответы (1)
1) Дано целое число N. Написать программу, заменяющую его 1, если число меньше нуля, и увеличивающую его на 6, если число больше или равно нулю. 2) Даны два числа a и b. Написать программу, которая выводит номер большего из них
Ответы (1)
Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел. Дана строка, содержащая пробел.
Ответы (1)