Задать вопрос
5 мая, 21:29

Составить программу которая формирует массив из 9 случайных целых чисел на промежутке от - 30,30 и вычислите:

а) сумму отрицательных чисел

б) произведение чётных чисел

+1
Ответы (1)
  1. 5 мая, 21:38
    0
    Var

    mas: array [1 ... 9] of integer;

    summ, count: integer;

    i: integer;

    begin

    randomize;

    summ : = 0;

    count : = 1;

    for i : = 1 to 9 do

    begin

    mas[i] : = random (-30, 30) ;

    write (mas[i] : 4) ;

    if mas[i] < 0 then summ : = summ + mas[i];

    if mas[i] > 0 then count : = count * mas[i];

    end;

    writeln ('') ;

    writeln ('Сумма отрицательных элементов: ', summ) ;

    writeln ('Произведение положительных элементов: ', count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая формирует массив из 9 случайных целых чисел на промежутке от - 30,30 и вычислите: а) сумму отрицательных чисел ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Составьте программу которая формирует массив из 16 случайных чисел от - 20 до 20 и: а) находит элементы с нулевыми значениями б) находит индексы четных элементов в) подсчитывает количество отрицательных элементов г) определяет, есть ли в этом
Ответы (1)