Задать вопрос
2 июня, 21:28

Написать программу вычисления стоимости поездки на автомобиле на дачу (туда и обратно).

Исходными данными являются: расстояние до дачи (в километрах) ; количество бензина, которое

потребляет автомобиль на 100 км пробега; цена одного литра бензина.

С пояснениями.

Вычисление стоимости поездки на дачу и обратно.

Расстояние до дачи (км) - > 67

Расход бензина (литров на 100 км пробега) - > 8.5 Цена литра бензина (руб.) - > 6.5

Поездка на дачу и обратно обойдется в 74.04 руб.

+5
Ответы (1)
  1. 2 июня, 23:27
    0
    S, r, c, ans: real;

    begin

    readln (s, r, c) ; / / считываем расстояние, расход, стоимость 1 литра

    ans : = (s / 100) * r * c * 2;

    / / формула вычисления стоимости s / 100 - коэффициент затраты его умножаем на расход / / на 100 км и умножаем на стоимость - это путь в 1 сторону умножив на 2 получаем путь

    //туда обратно.

    writeln (ans:0:2) ; / / форматированный вывод ответа с точностью 2 знака после запятой

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу вычисления стоимости поездки на автомобиле на дачу (туда и обратно). Исходными данными являются: расстояние до дачи (в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
16. Написать программу на языке Paskal вычисления стоимости поездки на автомобиле на дачу (туда и обратно).
Ответы (1)
Составьте программу вычисления стоимости поездки на дачу и обратно. Исходными данными являются: S - расстояние до дачи в километрах; B - количество бензина в литрах, которое потребляет автомобиль на 100 километров пробега;
Ответы (1)
Написать программу стоимости поездки на автомобиле на дачу. Исходными данными являются: расстояне до дачи, кол-во бензина, которое употребляет автомобиль на 100 км пробега, цена одного литра бензина
Ответы (1)
Составить алгоритм (нарисовать схему) и составить программу по следующей задачи: Вычислить стоимость поездки на автомобиле на дачу (туда и обратно).
Ответы (1)
Помогите со составлением алгоритма расчета стоимости пробега 100 км для автомобиля по следующим условиям: 1. Если автомобиль имеет дизельный двигатель то цена топлива для него 16 руб/л а его расход равен 9 литров на 100 км 2.
Ответы (1)