Задать вопрос
8 декабря, 12:54

Дан двумерный целочисленный массив А. Сформировать одномерный массив В, состоящий из суммы элементов каждого столбца массива А.

+3
Ответы (1)
  1. 8 декабря, 13:01
    0
    Const

    n=10;

    m=5;

    var

    i, j, s:integer;

    a:array[1 ... m, 1 ... n]of integer;

    b:array[1 ... n]of integer;

    begin

    writeln ('Массив А:') ;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (10) ;

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    for j:=1 to n do

    begin

    s:=0;

    for i:=1 to m do s:=s+a[i, j];

    b[j]:=s;

    end;

    writeln ('Массив В:') ;

    for i:=1 to n do write (b[i]:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двумерный целочисленный массив А. Сформировать одномерный массив В, состоящий из суммы элементов каждого столбца массива А. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Что нужно изменить во 2-ом решении по сравнению с 1-ым решением? №1 Дан двумерный массив. Определить сумму элементов второго столбца массива, больших 10. Решение №1. program sum; var a: array[1 ... 10, 1 ...
Ответы (1)