Задать вопрос
30 января, 21:34

Решить задачу в Паскале.

С клавиатуры вводится время суток в часах (от 1 до 24). Необходимо составить программу, которая будет выводить на экран привествие согласно введенному времени.

Ввод:

1

Вывод:

Доброй ночи

+1
Ответы (2)
  1. 30 января, 22:34
    0
    Var

    time : Integer; begin

    writeln ('Введите, который час: ') ;

    readln (time) ;

    if (time > 23) or (time < 0) then

    writeln ('Так не бывает!') else

    begin

    if (time > = 0) and (time < 6) then writeln ('Доброй ночи!') ;

    if (time > = 6) and (time < 12) then writeln ('Доброе утро!') ;

    if (time > = 12) and (time < 18) then writeln ('Добрый день!') ;

    if (time > = 18) and (time < 24) then writeln ('Добрый вечер!') ;

    end;

    end.
  2. 31 января, 00:51
    0
    Program myp;

    var a:integer;

    begin

    readln (a) ;

    if a = 1 then writeln ('Доброй ночи') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу в Паскале. С клавиатуры вводится время суток в часах (от 1 до 24). Необходимо составить программу, которая будет выводить на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Как это решать? И что тут вообще надо сделать? A+B Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt Даны 2 числа a и b. Найти сумму этих чисел.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Написать программу, начинающуюся с команды Ввод, заканчивающуюся командой Вывод. Программе на ввод дается h1, m1, s1 и h2, m2, s2 Это часы минуты и секунды начала отсчета и конца отсчета времени.
Ответы (2)
Нужно определить что в введеном числе 24 часовой формат или 12 часовой формат и составить код в с++ Задача такое: №1 Input (стандартный ввод) Output (вывод) 11:00 24-часовый формат 23:00 №2 Input (стандартный ввод) Output (вывод) 09:20 12-часовый
Ответы (1)