Задать вопрос
13 мая, 08:04

Капитан Флинт зарыл клад на Острове сокровищ. Он оставил описание, как найти клад. Описание состоит из строк вида: "North 5", где слово - одно из "North", "South", "East", "West", - задает направление движения, а число - количество шагов, которое необходимо пройти в этом направлении.

Напишите программу, которая по описанию пути к кладу определяет точные координаты клада, считая, что начало координат находится в начале пути, ось OX направлена на восток, ось OY - на север.

Входные данные

На вход подается последовательность строк указанного формата. Гарантируется, что числа не превосходят 108.

Выходные данные

Необходимо вывести координаты клада - два целых числа через пробел. Гарантируется, что эти числа не превосходят 108.

+4
Ответы (1)
  1. 13 мая, 10:36
    0
    Var

    d: string;

    i, p, s, x, y, err: integer;

    begin

    x : = 0; y : = 0;

    for i : = 1 to 5 do

    begin

    readln (d) ;

    p : = Pos (' ', d) ;

    Val (Copy (d, p + 1, Length (d) - p + 1), s, err) ;

    d : = Copy (d, 1, p - 1) ;

    case d of

    'North': y : = y + s;

    'South': y : = y - s;

    'East': x : = x + s;

    'West': x : = x - s

    end

    end;

    Writeln (x, ' ', y)

    end.

    Тестовое решение:

    East 10

    North 12

    West 5

    South 2

    West 7

    -2 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Капитан Флинт зарыл клад на Острове сокровищ. Он оставил описание, как найти клад. Описание состоит из строк вида: "North 5", где слово - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу в Python 3.3 Напишите программу, которая вводит два целых числа, a и b (a < b), и выводит через пробел 5 случайных целых чисел на отрезке [ a, b ]. Входные данные Входная строка содержит два целых числа a и b, разделённых пробелом.
Ответы (1)
Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. Входные данные На вход программы подаётся символьная строка.
Ответы (1)
В питоне Напишите программу, которая вводит два целых числа, a и b (a < b), и выводит через пробел 5 случайных целых чисел на отрезке [ a, b ]. Входные данные Входная строка содержит два целых числа a и b, разделённых пробелом.
Ответы (1)