Задать вопрос
11 августа, 06:49

Данны три вещественных числа а, в, с. Определить существует ли треугольник со сторонами а, в, с. Написать програму на языке Паскаля.

+1
Ответы (1)
  1. 11 августа, 08:26
    0
    Условия существования треугольника - сумма 2 ух сторон больше 3 ей

    var a, b, c:real;

    e:boolean;

    begin

    read (a, b, c) ;

    if (a+b>c) and (a+c>b) and (b+c>a) then e:=true;

    writeln (e) ;

    end.

    если что то не понятно пишите в комменты
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Данны три вещественных числа а, в, с. Определить существует ли треугольник со сторонами а, в, с. Написать програму на языке Паскаля. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
1. (x делится без остатка на 2 и на 3) записать на языке паскаля. 2. (х не делится на 5) записать на языке паскаля. 3. (величина х не кратна 3) записать на языке паскаля.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
Помогите решить (python 3.6) Даны три натуральных числа a, b, c. Определите, существует ли треугольник с такими сторонами. Если треугольник существует, выведите строку YES, иначе выведите строку NO.
Ответы (1)
Написать програму для Паскаля: Дан линейный массив, содержащий положительные и отрицательные целые числа, n=10.
Ответы (1)