Задать вопрос
19 марта, 07:06

Помогите!

Дано трёхзначное число, определить кратна ли сумма его цифер числу а. Число 123, а=5

+3
Ответы (1)
  1. 19 марта, 08:22
    0
    Begin

    read (n, a) ;

    for i: = 1 to 3 do

    begin

    summ : = summ + n mod 10;

    summ : = summ div 10;

    end;

    if summ mod a = 0 then write ('кратно') else write ('не кратно') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите! Дано трёхзначное число, определить кратна ли сумма его цифер числу а. Число 123, а=5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Дано двузначное числи. Определит. А) кратна ли трем сумма его цифр Б) кратна ли сумма его цифр числу a.
Ответы (1)
Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Дано два числа. Если их сумма кратна 5, то прибавить 1, иначе вычесть 2. Результат вывести на экран. Написать на языке Packal
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Напишите программу на паскале Дано трехзначное число. Определить кратна ли сумма его цифр числу а. Пример работы программы: Входные данные Выходные данные 633 No 4 540 Yes 2
Ответы (1)