Задать вопрос
7 ноября, 01:56

По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. Программа получает на вход целое число n и должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), на которое приходится данный день.

+1
Ответы (1)
  1. 7 ноября, 05:46
    0
    Program gt;

    label 1;

    var n, i, s:integer;

    begin

    readln (n) ;

    s:=0;

    for i:=1 to 12 do

    begin

    if (i=1) or (I=3) or (i=5) or (i=7) or (i=8) or (i=10) or (i=12) then begin

    s:=s+31;

    if (n<=s) then begin

    writeln (n-s+31,' ', i) ;

    goto 1;

    end;

    end;

    if (i=2) then begin

    s:=s+28;

    if (n<=s) then begin

    writeln (n-s+28,' ', i) ;

    goto 1;

    end;

    end;

    if (i=4) or (i=6) or (i=9) or (i=11) then begin

    s:=s+30;

    if (n<=s) then begin

    writeln (n-s+31,' ', i) ;

    goto 1;

    end;

    end;

    end;

    1:

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)