Задать вопрос
30 января, 06:41

Составьте программу, печатающую слово в обратном порядке.

+2
Ответы (2)
  1. 30 января, 08:11
    0
    Var s:string; i:integer;

    Begin

    Readln (s) ; i:=length (s) ;

    while (i>0) and (s [ i]=' ') do i:=i-1;

    if i=0 then Writeln ('слова в строке не обнаружены')

    else repeat Write (s[ i]) ; i:=i-1 until (i=0) or (s[ i]=' ') ;

    End.
  2. 30 января, 08:12
    0
    Var

    s: string; i, n:

    byte; c: char;

    begin

    readln (s) ;

    n : = length (s) div 2;

    for i : = 1 to n do begin

    c : = s[i];

    s[i] : = s[length (s) - i+1];

    s[length (s) - i+1] : = c;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, печатающую слово в обратном порядке. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите рекурсивную функцию, печатающую все неотрицательные элементы массива в обратном порядке
Ответы (1)
1. Напишите программу, запрашивающую ваш год рождения, год рождения вашей мамы и печатающую, во сколько лет мама вас родила. 2. Напишите дружественную по отношению к пользователю программу.
Ответы (1)
1. Описать массив, подходящий для представления роста (в см) призывников в РА из 115 группы. 2. Написать программу, заполняющую массив данными (не упорядоченными) с клавиатуры и печатающую средний рост призывников. 3.
Ответы (1)
Составьте программу печатающую значение true если указанное высказывание является истинным и false в противном случае числа a и b выражают длины катетов одного прямоугольного треугольника, а c и d - другого. эти треугольники являются подобными
Ответы (1)
составьте программу печатающую значение true если указанное высказывание является истинным и false в противном случае сумма цифр данного трехзначного числа N является четным числом
Ответы (1)