Задать вопрос
4 апреля, 09:20

Доказать, что любую целочисленную денежную сумму, большую 7 руб., можно выплатить без сдачи трешками и пятерками. Для данного n > 7 найти такие целые неотрицательные a и b, что 3a + 5b = n.

Нужно написать на делфи

+2
Ответы (1)
  1. 4 апреля, 09:32
    0
    Var

    a, b, n: integer;

    begin

    read (n) ;

    if n<=7 then exit;

    for a : = 1 to n do

    for b : = 1 to n do

    if 3 * a + 5 * b = n then

    writeln ('3 * ', a, ' + 5 * ', b, ' = ', n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Доказать, что любую целочисленную денежную сумму, большую 7 руб., можно выплатить без сдачи трешками и пятерками. Для данного n > 7 найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Показать, что любую сумму, большую 7 копеек, можно выплатить, используя только 3-х и 5-ти копеечные монеты. (То есть, для любого целого N>7 найти такие целые числа x и y, что 3x+5y=N). Написать программу в Pascal
Ответы (1)
Гиперссылки на web-странице могут обеспечивать переход ... 1) на любую web-страницу любого сервера Internet 2) на любую web-страницу в пределах данного домена 3) на любую web-страницу данного сервера 4) в пределах данной web-страницы
Ответы (1)
В продаже имеются следующие компьютерные устройства: Клавиатура 1200 руб. Джойстик 2100 руб. Сканер 2500 руб. Системный блок 25000 руб. Мышь 990 руб. Акустические колонки 2600 руб. Принтер 4500 руб. Монитор 4500 руб.
Ответы (1)
Числа в языке Pascal различаются: А) как натуральные и целые; Б) как целые и вещественные; В) как натуральные и вещественные; Г) как целые и иррациональные; Д) как целые и рациональные.
Ответы (1)
Дан двумерный массив размером n*m, заполненный случайными числами. Найти сумму его элементов, расположенных между максимальным и минимальным элементами (включая оба этих числа) - программный код для делфи
Ответы (1)