Задать вопрос
18 июня, 02:52

Требовалось написать программу, при выполнении которой с клавиатуры вводится натуральное число, не превосходящее 10^8, и выводится его первая цифра. Ученик написал такую программу:

var n:longint;

begin

read (n) ;

while n>10 do

begin

n:=n mod 10

end;

write (n) ;

end.

1) Напишите, что выведет эта программа при вводе числа 1984.

2) Приведите пример числа, при вводе которого программа выдаст верный ответ.

3) Найдите в программе все ошибки.

+3
Ответы (1)
  1. 18 июня, 04:26
    0
    1) 4

    2) 7

    3) мы в цикле берем остаток от деления на 10 = > последнюю цифру, нужно поменять на n:=n div 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Требовалось написать программу, при выполнении которой с клавиатуры вводится натуральное число, не превосходящее 10^8, и выводится его ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы