Задать вопрос
8 февраля, 22:12

Для заданного положительного вещественного числа A необходимо найти максимальное целое число K, при котором выполняется неравенство 1+1/2 + ... + 1/K
var a, s: real;

k: integer;

begin

read (a) ;

k : = 1;

s : = 1;

while s < a do begin

s : = s + 1.0/k;

k : = k + 1;

end;

write (k) ;

end.

Последовательно выполните следующее.

1. Напишите, что выведет эта программа при вводе числа 1.2.

2. Приведите пример числа, при вводе которого программа выведет правильный ответ.

3. Найдите в программе все ошибки (их может быть одна или несколько). Для каждой ошибки выпишите строку, в которой она допущена, и приведите эту же строку в исправленном виде.

+4
Ответы (1)
  1. 8 февраля, 23:03
    0
    1) 2

    2) Для начала об ошибке: Дело в том, что программа дважды прибавляет 1 к сумме прогрессии.

    1.6

    3) k:=1 меняем на k:=2

    writeln (k) меняем на writeln (k-2)

    //Однако, есть одна проблема. Если число a меньше или равно 1, программа возвращает 0. В начале прогрессии в любом случае будет 1, а потом уже 1/2 1/3 и т. д ...
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для заданного положительного вещественного числа A необходимо найти максимальное целое число K, при котором выполняется неравенство 1+1/2 + ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Опишите переменные для размещения в них: - пола человека (один символ) ; - целого положительного двузначного числа; -целого положительного трёхзначного числа; -целого положительного четырёхзначного числа; -небольшого вещественного числа;
Ответы (1)
Оператор цикла while ... do отличается от цикла for ... to, тем что 1. выполняется хотя бы один раз 2. выполняется хотя бы один раз 3. может не выполняться ни разу 4. выполняется известное число раз 5. выполняется неизвестное число раз
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Для хранения вещественного числа используется ячейка памяти размером 4 байта. Размер поля для хранения абсолютной величины мантиссы числа составляет 20 битов. Каково максимальное число, которое можно сохранить в такой ячейке?
Ответы (1)
Описать массив А который состоит из 14 элементов вещественного типа, нумерация начинаеться с 1 Описать массив f который состоит из 16 элементов вещественного типа, нумерация начинается с 1
Ответы (1)