Задать вопрос
23 апреля, 16:55

Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания.

Пример:

10 15 5

5 10 15

+5
Ответы (2)
  1. 23 апреля, 18:59
    0
    Program Program1;

    var arr: array[1 ... 3] of real;

    i, z, h: integer;

    procedure swap (var x, y: real) ;

    var t: real;

    begin t : = x; x : = y; y : = t

    end;

    begin

    writeln ('Введите три числа:') ;

    for i : = 1 to 3 do read (arr[i]) ;

    for h : = 1 to 3 - 1 do

    for z : = 1 to 3 - h do

    if arr[z] > arr[z + 1] then

    swap (arr[z], arr[z + 1]) ;

    for i : = 1 to 3 do write (arr[i], ' ') ;

    end.
  2. 23 апреля, 20:45
    0
    const

    Count = 3;

    var a : array [1 ... Count] of Integer;

    i, b, c: Integer;

    begin

    Writeln ('Введите числа:') ;

    for i : = 1 to Count do

    begin

    Write (i,': ') ;

    Readln (a[i]) ;

    end;

    for i : = 1 to Count do

    for b : = 1 to Count do

    if a[i] < a[b] then

    begin

    c : = a[i];

    a[i] : = a[b];

    a[b] : = c;

    end;

    for i : = 1 to Count do

    Write (a[i], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: 10 15 5 5 10 15 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать в Паскале процедуру с изменяемым параметром. помогите хотя бы с одним. Уровень A. Напишите процедуру, которая переставляет три переданные ей числа в порядке возрастания. Пример: Введите три натуральных числа: 10 15 5 5 10 15 Уровень B.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Напишите функцию int reverse (int n) (C/C++), function reverse (n:integer) : integer (Pascal), которая переставляет цифры числа в обратном порядке.
Ответы (1)
Pascal ABC Напишите программу, которая находит три наименьших элемента массива и переставляет их в начало массива. Остальные элементы должны следовать далее в том же порядке. Входные данные Первая строка содержит размер массива N.
Ответы (1)
Напишите программу, которая переставляет элементы массива в обратном порядке без использования дополнительного массива.
Ответы (1)