Задать вопрос
18 августа, 14:18

составить программу вывода N случайных целых чисел диапазона от 0 до 50. определить сколько среди них четных, а сколько нечетных

+5
Ответы (1)
  1. 18 августа, 16:45
    0
    Program gt;

    var a, l, k, n, i:integer;

    begin

    read (N) ;

    randomize;

    k:=0;

    l:=0;

    for i:=1 to n do

    begin

    a:=random (50) ;

    if (a mod 2=0) then k:=k+1 else l:=l+1;

    write (a,' ') ;

    end;

    writeln;

    writeln ('четные=', k) ;

    writeln ('не четные=', l) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «составить программу вывода N случайных целых чисел диапазона от 0 до 50. определить сколько среди них четных, а сколько нечетных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Ответьте в кумире или Паскале 1. Найти среднее арифметическое значений всех элементов массива, состоящего их случайных положительных чисел. 2. В массиве из 15-ти целых случайных чисел из диапазона [-30; 70] найти минимальный положительный элемент. 3.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)