Задать вопрос
10 февраля, 01:03

Некоторая вещь стоит A рублей и B копеек. Было куплено N таких вещей. Запишите общую стоимость покупки в рублях и копейках в переменные C1 и С2. Значения переменных A и N не превосходят 30000, а значение переменной B не превосходит 100. Переменные С1 и С2 имеют тип longint. Другие переменные не использовать.

+2
Ответы (1)
  1. 10 февраля, 04:57
    0
    Var C2, C1: longint;

    a, b, n: integer;

    begin

    readln (a, b, n) ;

    b : = b + a * 100;

    C1 : = b * n;

    C2 : = C1 mod 100;

    C1 : = C1 div 100;

    writeln (C1, ',', C2) ;

    end.

    Вот так =)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Некоторая вещь стоит A рублей и B копеек. Было куплено N таких вещей. Запишите общую стоимость покупки в рублях и копейках в переменные C1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачу! Пирожок в столовой стоит a рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: a, b, n и должна вывести два числа: стоимость покупки в рублях и копейках
Ответы (1)
Напишите в ответе наименьшее значение входной переменной k, при котором программа выдаёт ответ 21. Для Вашего удобства программа приведена на пяти языках программирования.
Ответы (2)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
Задание 1. Некоторая сумма денег выражена в копейках, например 317, 5050, 100. Записать данную сумму в гривнах и копейках, т. е. в виде: 3 грн. 17 коп., 50 грн. 50 коп, 1 грн. 00 коп. (Количество копеек всегда выражается двумя цифрами)
Ответы (1)
Задача1 Введите числа в переменные a, b и c и напишите программу, которая меняет местами значения переменных по следующей схеме, чтобы в переменной а оказалось первоначальное значение переменной с, в переменной b - значение а, в переменной с -
Ответы (1)