Задать вопрос
13 июля, 10:04

Паскаль

1. Найти все двухзначные числа, такие, что если к сумме цифр числа прибавить квадрат этой суммы, то получится это число.

2. Найти четырехзначное число, которое при делении на 133 дает в остатке 125, а при делении на 134 остаток 111.

+5
Ответы (1)
  1. 13 июля, 10:21
    0
    Program gt;

    var i, p, s, q:integer;

    begin

    for i:=10 to 99 do

    begin

    p:=i;

    s:=0;

    while p>0 do

    begin

    q:=p mod 10;

    p:=p div 10;

    s:=s+q;

    end;

    if (s+s*s=i) then writeln (i) ;

    end;

    end.

    2)

    program gt;

    var i:integer;

    begin

    for i:=1000 to 9999 do

    begin

    if (i mod 133=125) and (i mod 134=111) then writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль 1. Найти все двухзначные числа, такие, что если к сумме цифр числа прибавить квадрат этой суммы, то получится это число. 2. Найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в python: найдите все пятизначные числа, которые при делении на 133 дают в остатке 125, а при делении на 134 дают в остатке 111.
Ответы (1)
Паскаль найдите все пятизначные числа которые делении на 133 дают в остатке 125 а при делении на 134 в остатке 111
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Выполнить алгоритм: 1) Найти сумму чисел 1 и 3; 2) Прибавить к полученной сумме число 5; 3) Прибавить к полученной сумме число 7; 4) Прибавить к полученной сумме число 9; 5) Прибавить к полученной сумме число 11; 6) Сообщить результат.
Ответы (2)
Выполните алгоритм 1) Найти сумму чисел 1 и 3. 2) Прибавить к полученной сумме число 5. 3) Прибавить к полученной сумме число 7. 4) Прибавить к полученной сумме число 9. 5) Прибавить к полученной сумме число 11. 6) Напечатай результат.
Ответы (2)