Задать вопрос
6 февраля, 13:13

Напишите программу, которая по введенному целому числу А (0≤ А ≤ 999999) находит сумму цифр этого числа S.

+2
Ответы (1)
  1. 6 февраля, 15:10
    0
    Var a, col:integer;

    s:string;

    begin

    readln (a) ;

    if (a999999) then

    writeln ('Число А не соответствует условию')

    else

    begin

    s:=IntToStr (a) ; / / Переводим из числовой в строковую величину

    col:=length (s) ;

    writeln ('Количество: ', col) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая по введенному целому числу А (0≤ А ≤ 999999) находит сумму цифр этого числа S. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая заполняет массив из N = 10 случайными числами в диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу X.
Ответы (1)
Уровень C. Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [10,50], выводит его на экран, а затем находит индексы всех элементов, равных введённому числу X.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)