Задать вопрос
20 февраля, 12:10

Найти количество отрицательных элементов в массиве из 14 чисел выбранных случайным образом в диапазоне от - 13 до 13

+4
Ответы (1)
  1. 20 февраля, 16:08
    0
    Program chik;

    var a, k, i:integer;

    begin

    k:=0;

    for i:=1 to 14 do

    begin

    a:=trunc ((13 - (-13)) * random-13) ;

    if (a<0) then k:=k+1;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти количество отрицательных элементов в массиве из 14 чисел выбранных случайным образом в диапазоне от - 13 до 13 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Сформировать одномерный массив из N элементов (значения элементов задаются случайным образом в диапазоне от - 20 до 80). Вывести массива на экран.
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
Паскаль, помогите! В числовом массиве из 10 элементов, заданных случайным образом от - 100 до 500. Найти: 1) сумму положительных элементов, стоящих на чётных местах; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах;
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)