Задать вопрос
22 сентября, 04:50

Программа в Pascal

определить количество положительных элементов в двумерном массиве 5x4

+1
Ответы (1)
  1. 22 сентября, 06:52
    0
    Const n=5;

    const m=4;

    var i, j, Sch: integer;

    a:array[1 ... n, 1 ... m] of integer;

    Begin

    Sch:=0;

    For i:=1 to 5 do begin

    For j:=1 to 4 do begin

    a[i, j]:=random (73) - 23;

    write (a[i, j], ' ') ;

    If a[i, j]>0 then Sch:=Sch+1;

    end;

    end;

    writeln;

    writeln ('kollichestvo = ', Sch) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа в Pascal определить количество положительных элементов в двумерном массиве 5x4 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)