Задать вопрос
12 июня, 15:25

Натйти максимальный по модулю элемент и его порядковый номер. составить программу в паскале

+5
Ответы (1)
  1. 12 июня, 15:58
    0
    Var a: array [0 ... 10] of integer;

    i, m: integer;

    begin

    for i : = 0 to 10 do

    begin

    a[i] : = random (50) - 25;

    writeln ('[', i, '] = > ', a[i]) ;

    end;

    for i : = 0 to 10 do

    if (abs (a[i]) > abs (a[m])) then

    m : = i;

    writeln ('[', m, '] = > ', a[m]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Натйти максимальный по модулю элемент и его порядковый номер. составить программу в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На с + + Мальчик-романтик из царства-государства дарит цветы незнакомым дамам-девушкам. Известно, что он дарит цветок каждой пятой даме-девушке, но при этом не дарит цветок, если порядковый номер дамы-девушки кратен 25.
Ответы (1)
Дан массив A (4). Найти максимальный элемент массива и его порядковый номер. На паскале.
Ответы (1)
Определить максимальный элемент массива B (размерность 50) и его порядковый номер Xi>0. В паскале.
Ответы (1)
В pascal. 1) Заполните массив случайными числами из интервала [-50; 50), вывести на экран, посчитать сумму отрицательных элементов. 2) Ввести одномерный массив, вывести его на экран, найти максимальный элемент и его порядковый номер.
Ответы (1)
Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не повторяется. Входные данные Первая строка содержит размер массива N.
Ответы (1)