Задать вопрос
3 февраля, 05:32

В театре работает n актеров. Известно, что среди них a - высоких, b - голубоглазых и с - блондинов. Для главной роли в новом спектакле режиссеру требуется только один высокий голубоглазый блондин. Чтобы спланировать свое время для беседы с каждым таким артистом из труппы театра, режиссеру необходимо узнать, какое максимальное или какое минимальное количество артистов из работающих в театре подходит для этой роли.

Требуется написать программу, которая по заданным числам n, a, b и с определяет минимальное или максимальное количество актеров, с которыми режиссер должен переговорить.

+2
Ответы (1)
  1. 3 февраля, 05:50
    0
    var

    a, b, c, n: integer;

    begin

    writeln ('Сколько всего актеров в театре?') ;

    readln (n) ;

    writeln ('Сколько есть высоких среди актеров?') ;

    readln (a) ;

    writeln ('Сколько есть голубоглазых среди актеров?') ;

    readln (b) ;

    writeln ('Сколько есть актеров блондинов?') ;

    readln (c) ;

    if a < b then

    if a < c then writeln ('Максимальное количество высоких голубоглазых блондинов: ', a)

    else writeln ('Максимальное количество высоких голубоглазых блондинов: ', c)

    else if b < c then writeln ('Максимальное количество высоких голубоглазых блондинов: ', b)

    else writeln ('Максимальное количество высоких голубоглазых блондинов: ', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В театре работает n актеров. Известно, что среди них a - высоких, b - голубоглазых и с - блондинов. Для главной роли в новом спектакле ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Программисты помогайте) Написать программу на паскале, которая по заданным трем числам определяет, является ли сумма каких-либо двух из них положительной
Ответы (1)
Укажите виды циклов А) с заданным условием продолжения работы Б) с полным ветвлением В) с заданным числом повторений Г) с заданным условием окончания работы Д) разветвляющийся
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)