Задать вопрос
24 февраля, 07:32

Найти количество различных цифр данного натурального числа

+5
Ответы (1)
  1. 24 февраля, 07:59
    0
    Uses crt;

    var i, ans:integer;

    s:string;

    u:set of char;

    begin

    read (s) ;

    for i:=1 to length (s) do

    if not (s[i] in u) then begin

    inc (ans) ;

    u:=u+[s[i]];

    end;

    writeln (ans) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти количество различных цифр данного натурального числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Pascal. Требуется помощь. Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для числа 128 сумма цифр 11, для числа 345 сумма цифр 12.
Ответы (1)
1) найти количесво делителей натурального числа, сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа верно ли, что первая цыфраа данного числа чётная?
Ответы (1)