Задать вопрос
9 декабря, 18:11

С клавиатуры вводится целое число, содержащие не более 7 цифр. Определить максимальную цифру в этом числе.

Программа Паскаль. Цикл с пред условием

+4
Ответы (1)
  1. 9 декабря, 20:25
    0
    Program maxx;

    var max, n, k, i:integer;

    begin

    writeln ('введите кол-во чисел') ;

    readln (k) ;

    max:=0;

    for i:=1 to k do

    begin

    readln (n) ;

    if n>max then max:=n;

    end;

    writeln (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится целое число, содержащие не более 7 цифр. Определить максимальную цифру в этом числе. Программа Паскаль. Цикл с пред ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводится целое число, содержащее не более 7 цифр. Определить максимальную цифру в этом числе. Программа Pascal ABC. Нужно использовать цикл с предусловием.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Паскаль, цикл с предусловием while. Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)