Задать вопрос
19 октября, 13:06

Составьте программу для нахождения среднего арифметического двухзначных чисел кратных 3

+1
Ответы (1)
  1. 19 октября, 13:41
    0
    Допустим дана последовательность числе из n элементов

    Pascal

    var

    mas:array[1 ... 100] of integer;

    n2, sum, i, n:intger;

    begin

    readln (n) ;

    sum:=0;

    n2:=0;

    for i:=1 to n do

    read (mas[i]) ;

    for i:=1 to n do

    begin

    if (mas[i] mod 3 = 0) and (mas[i]>9) and (mas[i]<100) then

    begin

    n2:=n2+1;

    sum:=sum+mas[i];

    end;

    end;

    writeln (sum/n2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу для нахождения среднего арифметического двухзначных чисел кратных 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы