Задать вопрос
21 июня, 15:22

как найти сумму чисел кратных 7 от 1 до n включительно

+4
Ответы (1)
  1. 21 июня, 18:20
    0
    Program gt;

    var n, s, i:integer;

    begin

    read (N) ;

    s:=0;

    for i:=1 to n do

    begin

    if (i mod 7=0) then s:=s+i;

    end;

    writeln ('сумма чисел кратных 7=', s) ;

    end.

    mod-это остаток от деления n на 7

    если остаток равно 0 значит это число нацело делится на 7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «как найти сумму чисел кратных 7 от 1 до n включительно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
1) Вывести на экран числа кратные 16 от 31 до M (M>31) ; 2) Найти сумму 5 натуральных чисел кратных 13; 3) Найти произведение N натуральных чисел кратных 11; 4) Вывести на экран семь первых чисел кратных 7.
Ответы (1)
Задачи: 1) Найти насколько (количество) двузначных чисел кратных 3 больше чем двузначных чисел кратных 5.
Ответы (1)
1. Написать программу нахождения произевдения всех однозначных чисел не кратных 5. 2. Найти кол-во элементов кратных 7, но не кратных 14 3. Найти минимальный двузначный элемент массива
Ответы (1)