Задать вопрос
12 марта, 11:38

Паскаль

Даны целое число k (1≤ k≤ 180) и последовательность цифр 10111213 ... 9899, в которой выписаны подряд все двухзначные числа. Определить k-ю цифру.

+3
Ответы (1)
  1. 12 марта, 14:13
    0
    Var

    k, i:integer;

    s, x:string;

    begin

    for i:=10 to 99 do s:=s+IntToStr (i) ;

    writeln (s) ;

    write ('Введите число k: ') ;

    readln (k) ;

    x:=s[k];

    writeln (k,'-я цифра: ', x)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Даны целое число k (1≤ k≤ 180) и последовательность цифр 10111213 ... 9899, в которой выписаны подряд все двухзначные числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дано натуральнок K от 1 до 180. Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213 ... 9899. Формат входных данных Файл содержит число k-позиция искомой цифры.
Ответы (1)
Есть числовой ряд: 101112 ... 979899, в котором подряд выписаны все двухзначные числа. Определить двухзначное число из этого ряда, образованное парой цифр, в которую входит k-ая цифра. k вводится и лежит в диапазоне от 1 до 180.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)