Задать вопрос
17 сентября, 09:02

Даны действительные положительные числа a, b, c, которые задают длины сторон треугольника и угол между ними. Напишите программу (Паскаль), позволяющую найти длину третьей стороны треугольника и два остальных угла.

+4
Ответы (1)
  1. 17 сентября, 12:35
    0
    Var

    a, b, c, aa, ab, ac : real;

    function Arcsin (x : real) : real; begin Arcsin : = Arctan (x/Sqrt (1-sqr (x))) ; end;

    //магия. в паскале нет функции арксинус или арккосинус, поэтому приходится выражать через арктангенс.

    begin

    read (a, b, ac) ;

    ac : = ac * pi / 180; / / перевод в радианы

    c : = sqrt (sqr (a) + sqr (b) - 2 * a * b * cos (ac)) ;

    aa : = arcsin (a * sin (ac) / c) ;

    ab : = pi - aa - ac;

    writeln (a, ' ', b, ' ', c) ;

    writeln (aa * 180 / pi, ' ', ab * 180 / pi, ' ', ac * 180 / pi) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны действительные положительные числа a, b, c, которые задают длины сторон треугольника и угол между ними. Напишите программу (Паскаль), ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
2 задачи по программированию: 1) Три точки заданы своими координатами (x1, y1), (x2, y2), (x3, y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого
Ответы (1)
Даны три произвольных числа a, b, c, значение которых задают длины сторон треугольника. Выведите 0, если нельзя построить треугольник с такими длинами сторон; 3, если получается равностороний треугольник; 2 равнобедренный; 1 в остальных случаях.
Ответы (1)
1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного. 2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)