Задать вопрос
16 декабря, 11:51

С клавиатуры вводятся два натуральных числа N и K (0
Пример входных данных: 2 5

Пример выходных данных: 10

+1
Ответы (1)
  1. 16 декабря, 13:34
    0
    Var

    simple: array[1 ... 10000] of integer;

    i, j, a, b, simple_n, s: integer;

    is_simple: boolean;

    begin

    read (a, b) ;

    for i : = 2 to b do begin

    is_simple : = true;

    for j : = 1 to simple_n do

    is_simple : = is_simple and (i mod simple[j] 0) ;

    if is_simple then begin

    simple_n : = simple_n + 1;

    simple[simple_n] : = i;

    writeln (i) ;

    if i > = a then s : = s + i;

    end;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся два натуральных числа N и K (0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)