Задать вопрос
1 января, 19:16

Найти сумму и произведение цифр случайного трехзначного числа

+4
Ответы (1)
  1. 1 января, 21:23
    0
    Var

    n: integer;

    a, b, c: byte;

    begin

    randomize;

    n : = random (900) + 100;

    writeln (n) ;

    a : = n div 100;

    b : = n div 10 mod 10;

    c : = n mod 10;

    writeln ('Сумма: ', a+b+c) ;

    writeln ('Произведение: ', a*b*c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму и произведение цифр случайного трехзначного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Сумма цифр случайного трехзначного числа (Например, число 123 - это и есть цифры трехзначного числа, для общего случая это будет xyz. Обозначает за x - первое число, y - второе число, z - третье число. Результатом будет r=x+y+z)
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)