Задать вопрос
2 декабря, 13:38

Составьте программу вычисления площади кольца по значениям внутреннего и внешнего радиусов, используя подпрограмму вычисления площади круга (два варианта: с процедурой и с функцией)

+5
Ответы (1)
  1. 2 декабря, 14:32
    0
    Var

    r1, r2: real;

    procedure pCircleSquare (r: real; var S: real) ;

    begin

    s : = Pi * sqr (r) ;

    end;

    function fCircleSquare (r: real) : Real;

    begin

    fCircleSquare : = Pi * sqr (r) ;

    end;

    begin

    Write ('r1, r2 = ') ;

    ReadLn (r1, r2) ;

    writeln ('Функция S = ', abs (fCircleSquare (r1) - fCircleSquare (r2)) : 5:2) ;

    pCircleSquare (r1, r1) ;

    pCircleSquare (r2, r2) ;

    writeln ('Процедура S = ', abs (r1 - r2) : 5:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления площади кольца по значениям внутреннего и внешнего радиусов, используя подпрограмму вычисления площади круга ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу вычисления площади кольца. Ниже приведен рекомендуемый вид экрана во время выполнения программы.
Ответы (1)
Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым. Используя подпрограмму вывести на экран все простые числа из промежутка целых чисел, определенного пользователем. Pascal ABC
Ответы (1)
Написать подпрограмму для поиска максимального из всех двухзначных чисел в строке. Если в строке нет ни одного двухзначного числа, то подпрограмма должна вернуть 0. function CalcMax (s:string) : integer; с процедурой val
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Даны основания и высоты двух трапеций. Составьте программу для вычисления суммы их площадей. Используйте подпрограмму вычисления площади одной трапеции. а=2, в=3, h=2.5 а=4.1, в=5, h=3.3
Ответы (1)