Задать вопрос
22 мая, 15:10

Найти количество не отрицательных нечетных элементов двумерного массива.

+2
Ответы (1)
  1. 22 мая, 16:35
    0
    На паскале

    ---

    uses crt;

    const n=3;

    m=3;

    var a: array [1 ... n, 1 ... m] of integer;

    x, y, k: integer;

    begin

    k:=0;

    for x:=1 to n do begin

    for y:=1 to m do begin

    a[x, y]:=random (21) - 10;

    if a[x, y] mod 2=1 then inc (k) ;

    write (a[x, y]:4) ;

    end;

    writeln;

    end;

    writeln ('Количество неотрицательных нечетных элементов: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти количество не отрицательных нечетных элементов двумерного массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)