Задать вопрос
7 февраля, 08:49

Задано N целых чисел. Вам необходимо найти среднее арифметическое этих чисел. Гарантируется, что среднее арифметическое всегда целое.

+4
Ответы (1)
  1. 7 февраля, 12:29
    0
    Var count, a, b, N, i: integer;

    Begin

    writeln ('N = ') ;

    readln (N) ;

    for i : = 1 to N do

    begin

    write (i, ': ') ;

    readln (a) ;

    b : = b + a;

    count : = count + 1;

    end;

    writeln ('> ', b/a) ;

    end.

    Вот, прошу =)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задано N целых чисел. Вам необходимо найти среднее арифметическое этих чисел. Гарантируется, что среднее арифметическое всегда целое. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программы для решения задач. Используйте операция div и mod. 1. Задано двузначное число. Найдите среднее арифметическое цифр числа. 2. Задано двузначное число. Найдите разность между количеством десятков и единиц.
Ответы (2)
Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере (пробелы важны!) : Входные данные Вводится целое число (гарантируется, что число находится в диапазоне от - 1000 до + 1000).
Ответы (1)
Вопрос №591394 (тип: C) Даны два целых числа a и b. Напишите программу, которая находит среднее арифметическое квадратов всех целых чисел от a до b Входные данные: В первой строке вводятся два целых числа a и b (a
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)