Задать вопрос
12 ноября, 17:26

Вводятся 4 числа. Известно, что одно из них отлично от трѐх других. Нужно вывести это число. При любых входных данных алгоритм должен выполнять не более двух операций сравнения.

+4
Ответы (1)
  1. 12 ноября, 20:06
    0
    Program gt;

    label 1;

    var a, b, c, d:integer;

    begin

    read (a, b, c, d) ;

    if (a=b) then begin

    if (a=c) then writeln (d) else writeln (c) ;

    goto 1;

    end;

    if (a=c) then writeln (b) else writeln (a) ;

    1:

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводятся 4 числа. Известно, что одно из них отлично от трѐх других. Нужно вывести это число. При любых входных данных алгоритм должен ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Имя входного файла: стандартный ввод Имя выходного файла: стандартный вывод Ограничение по времени: 1 секунда Ограничение по памяти: 256 мегабайт У Жарасхана есть массив а из n чисел, к каждому числу массива Жарасхан должен применять лишь одну
Ответы (1)
Вводятся два натуральных числа. если оба числа чётные, то вывести большее из них. если оба числа не чётные, то вывести меньшее из них. если одно чётное, а другое не чётное, то вывести их произведение на экран.
Ответы (2)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Из-за непогоды были отменены рейсы самолетов. Ненадолго проглянуло солнце: на N часов и M минут. Напишите программу, которая определяет, сколько самолетов успеет вылететь за это время, если на взлетной полосе может быть только один самолет, а
Ответы (1)