Задать вопрос
19 февраля, 16:29

Задача 1 Определить кол-во цифр в числе.

Задача 2 Напечатать те натуральные числа квадрат которых не превышает n.

Задача 3 Найти первое натуральное число куб которого больше n.

+5
Ответы (1)
  1. 19 февраля, 18:48
    0
    Var

    a, c : integer;

    begin

    read (a) ;

    c : = 0;

    while a > 0 do

    begin

    c : = c + 1;

    a : = a div 10;

    end;

    write (c) ;

    end.

    var

    i, n : integer;

    begin

    read (n) ;

    for i : = 1 to trunc (sqrt (n)) do

    write (i, ' ') ;

    end.

    var

    n, i : integer;

    begin

    i : = 1;

    while i*i*i < = n do

    i : = i + 1;

    writeln (i) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 1 Определить кол-во цифр в числе. Задача 2 Напечатать те натуральные числа квадрат которых не превышает n. Задача 3 Найти первое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)