Задать вопрос
17 июля, 12:00

В массиве A найти максимальный отрицательный элемент и заменить его значением первого нулевого элемента

+5
Ответы (1)
  1. 17 июля, 15:05
    0
    Program vladimir37005;

    const n=5;

    var a:array[1 ... n] of integer;

    i, min, k:integer;

    begin

    for i:=1 to n do begin

    write ('a[', i,']=') ;

    read (a[i]) ;

    end;

    min:=a[1]; k:=1;

    for i:=1 to n do

    if (A[i] < min)

    then begin

    min:=A[i];

    k:=i;

    end;

    for i:=1 to n do

    if (a[i] min)

    then begin

    min:=a[i];

    k:=i;

    end;

    a[k]:=0;

    for i:=1 to n do

    write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве A найти максимальный отрицательный элемент и заменить его значением первого нулевого элемента ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если хотя бы один элемент однородного массива отрицательный, то вывести сообщение элемент отрицательный, если иначе - все положительные.
Ответы (1)
Дан массив состоящий из 30 элементов. Найти в массиве максимальный элемент, вывести его значение и номер на экран. Отрицательный элемент массива заменить на равные по модулю положительные элементы.
Ответы (1)
Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не повторяется. Входные данные Первая строка содержит размер массива N.
Ответы (1)
В одномерном массиве А (10) найти максимальный элемент, вывести его значение и индекс. Заменить все четные элементы значением максимального элемента. Полученный массив вывести на экран.
Ответы (1)
В одномерном массиве А (10) найти максимальный элемент, вывести его значение и индекс. Заменить все элементы большие 1, но меньшие 4 значением максимального элемента. Полученный массив вывести на экран.
Ответы (1)