Задать вопрос
5 февраля, 05:50

Напишите программу. В Паскале!

Дано n - натуральное четырёхзначное. Найти новое m, поменяв местами 1-2,3-4.

Пример: n=1234 - > m=2143.

+2
Ответы (1)
  1. 5 февраля, 09:39
    0
    Var n, m:string;

    begin

    readln (n) ;

    m:=n[2]+n[1]+n[4]+n[3];

    writeln (m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу. В Паскале! Дано n - натуральное четырёхзначное. Найти новое m, поменяв местами 1-2,3-4. Пример: n=1234 - > m=2143. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Получить новое слово удалив одну букву (Папка - папа) : потолок, колокол, перезвон, графин, программа, комната, получить новое слово поменяв местами буквы (Год - дог) пион. адрес, лапа, каприз, карета, ладошка, мошкара
Ответы (1)
Дано трехзначное целое число Х. Найти остаток от деления произведения всех его цифр на сумму всех его цифр. Вывести новое число Y, поменяв местами вторую и третью цифру числа X.
Ответы (1)
Алина задумала четырехзначное число из цифр 1,2,3,4. У задуманного числа и числа 1243 одинаковая цифра стоит в двух разрядах, а у задуманного числа и у числа 2143 одинаковых цифр в совпадающих разрядах нет.
Ответы (1)
1. Ввести целое число и найти сумму его цифр. Пример Введите целое число 1234 Сумма цифр числа 1234 равна 10 2. Вычислить в Паскале степень числа, используя цикл while
Ответы (1)
Расположите выражения сверху вниз в порядке возрастания их значений 1. 931 div 100 2. (1234 div 10) mod 10 3. 931 mod 100 4. (1234 mod 100) mod 10 5. (1234 div 100) mod 10 6. 931 mod 10 7.100 mod 10 8. 100 div 10
Ответы (1)