Задать вопрос
31 марта, 09:11

Составить программу нахождения наибольшего числа из введенных с клавиатуры. В Паскале с помощью цикла.

+4
Ответы (1)
  1. 31 марта, 13:04
    0
    Var max, n, c, i:integer;

    begin

    readln (n) ; / / сколько чисел будет всего введено

    readln (c) ;

    max:=c;

    for i:=1 to n-1 do begin

    readln (c) ;

    if max
    end;

    writeln (max) ;

    end.

    //это один из самых производительных алгоритмов, без лишних записей в массив и траты памяти
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу нахождения наибольшего числа из введенных с клавиатуры. В Паскале с помощью цикла. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Составьте программу, которая: а) Определяет коды двух введённых с клавиатуры символов; б) Выполняет операцию сцепления трёх введённых с клавиатуры символов; на Pascal
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
Помогите решить 2 задачи ... 1) Вывести на экран квадрат наибольшего из 2 введенных чисел? 2) Вывести на экран корень наибольшего из 3 введенных чисел?
Ответы (1)