Задать вопрос
17 декабря, 15:10

Написать программу через repeat.

Дано натуральное число n>10. найти первую цифру данного числа

+5
Ответы (1)
  1. 17 декабря, 16:56
    0
    var n: integer;

    begin

    readln (n) ;

    repeat

    n: = n div 10;

    until n<10;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу через repeat. Дано натуральное число n>10. найти первую цифру данного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Дано число. В этом числе необходимо изменить одну цифру таким образом, чтобы новое число делилось на 3 и было бы максимально возможным. В исходном числе нужно обязательно изменить одну цифру, даже если исходное число уже делилось на 3.
Ответы (1)
Нужно на C++ Дано число. В этом числе необходимо изменить одну цифру таким образом, чтобы новое число делилось на 3 и было бы максимально возможным. В исходном числе нужно обязательно изменить одну цифру, даже если исходное число уже делилось на 3.
Ответы (1)