Задать вопрос
15 марта, 21:35

Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К сожалению, проспать 14 часов ему не удалось, т. к. будильник зазвонил уже через 2 часа. Исследователь забыл, что на будильнике, имеющем 12-ти часовой циферблат, можно задать время до звонка только менее 12 часов. Требуется написать программу, которая определяет, сколько часов успеет проспать исследователь, прежде чем будильник его разбудит.

Входные данные: Два целых числа S и T (1 < S < 24, T < 12) - час, когда исследователь лег спать, и час, на который он установил будильник.

Выходные данные: Целое число - через сколько часов зазвонит будильник.

+2
Ответы (2)
  1. 16 марта, 00:09
    0
    Program gt;

    var k, s, t:integer;

    begin

    read (s, t) ;

    if (s<=12) then begin

    if (s<=t) then k:=t-s;

    if (s>t) then k:=t+12-s;

    end;

    if (s>12) then begin

    if (s<=t+12) then k:=t+12-s;

    if (s>t+12) then k:=24-s+t;

    end;

    writeln (k) ;

    end.
  2. 16 марта, 00:27
    0
    VB.

    Dim S As Integer ' 1<=S<=24

    Dim T As Integer ' T<=12

    S = InputBox ("S=")

    T = InputBox ("T=")

    Select Case S

    Case Is < = T

    MsgBox (T - S)

    Case Is > T

    If T = 12 Then MsgBox ((T + 12) - S) Else MsgBox (24 - (S - T))

    End Select
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. Используйте процедуру входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110
Ответы (1)