Задать вопрос
10 октября, 15:22

Тема: одномерные массивы, написать программу использую rite, riteln

задача; Все элементы кратные трем делятся на три, остальные умножаются на 3.

+3
Ответы (1)
  1. 10 октября, 17:14
    0
    Const N = ...; / / указываешь количество элементов массива

    var a:array [1 ... N] of integer;

    i:integer;

    begin

    for i:=1 to N do

    readln (a[i]) ;

    for i:=1 to N do begin

    if a[i] mod 3 = 0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;

    writeln (a[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Тема: одномерные массивы, написать программу использую rite, riteln задача; Все элементы кратные трем делятся на три, остальные умножаются ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы