Задать вопрос
10 ноября, 21:20

Выводится на экран последовательность 20 случайных чисел из промежутка [-10,10]. Определить количество отрицательных чисел больших - 5 в данной последовательности.

+2
Ответы (1)
  1. 11 ноября, 00:42
    0
    Uses crt;

    vara:array[1 ... 20]of integer;

    i, k:integer;

    begin

    for i:=1 to 20 do

    a[i]:=random (20) - 10;

    for i:=1 to 20 do

    write (a[i],' ')

    ; for i:=1 to 20 do begin

    if (a[i]-5) then

    k:=k+1;

    end;

    writeln;

    writeln ('кол-во отрицательных чисел больше - 5=', k)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Выводится на экран последовательность 20 случайных чисел из промежутка [-10,10]. Определить количество отрицательных чисел больших - 5 в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
При помощи датчика случайных чисел вводится последовательность a, состоящая из N (случайное трёхзначное число) целых положительных случайных 4-х значных чисел. Получить последовательность b, куда включить только простые числа из последовательности а.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)