Задать вопрос
2 марта, 22:27

Необходимо заполнить двумерный массив, как указано задании, в Pascal.

I - отвечает за номер строки.

J - отвечает за номер столбца.

Заполненные массивы должны выглядеть так:

a) при const n=3, m=3

1 2 1

2 3 2

1 2 1

в) при const n=5, m=5

1 2 3 2 1

2 1 2 1 2

3 2 1 2 3

2 1 2 1 2

1 2 3 2 1

+3
Ответы (1)
  1. 3 марта, 01:39
    0
    Program Task;

    Const N = 3;

    Var A: Array [1 ... N, 1 ... N] of Integer;

    d, p, n

    First, nLast, I, J, K: Integer;

    Begin

    nFirst : = 1;

    nLast : = N;

    p : = (N Div 2 + 1) ;

    For K : = 1 To p Do Begin

    If K = p Then

    Begin

    d : = p + 1;

    If d > 3 Then

    d : = 1;

    A[nFirst, nLast] : = d;

    Break;

    End;

    For J : = nFirst To nLast Do

    Begin

    If J < = p Then

    Begin

    d : = d + 1;

    End

    Else

    Begin

    d : = d - 1;

    End;

    A[nFirst, J] : = d;

    A[nLast, J] : = d;

    End;

    d : = 0;

    For I : = nFirst To nLast Do

    Begin

    If I < = p Then

    Begin

    d : = d + 1;

    End

    Else

    Begin

    d : = d - 1;

    End;

    A[I, nFirst] : = d;

    A[I, nLast] : = d;

    End;

    d : = 0;

    nFirst : = n

    First + 1;

    nLast : = nLast - 1;

    End;

    For I : = 1 To N Do

    Begin

    For J : = 1 To N Do

    Write (A[I, J], ' ') ;

    WriteLn;

    End;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Необходимо заполнить двумерный массив, как указано задании, в Pascal. I - отвечает за номер строки. J - отвечает за номер столбца. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Необходимо составить программу с двумерным массивом. Для заполнения данного массива нужно использовать генератор случайных чисел. I - отвечает за номер строки. J - отвечает за номер столбца.
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
Создайте двумерный массив X, имеющий четыре строки и три столбца и найдите в нем максимальный по абсолютному значению элемент, а также определите номер строки и столбца, содержащие этот элемент
Ответы (1)
Дан двумерный массив. Определить номер столбца, в котором расположен минимальный элемент четвертой строки массива. Если элементов с минимальным значением в этой строке несколько, то должен быть найден номер столбца самого левого из них. Паскаль.
Ответы (1)
Что нужно изменить во 2-ом решении по сравнению с 1-ым решением? №1 Дан двумерный массив. Определить сумму элементов второго столбца массива, больших 10. Решение №1. program sum; var a: array[1 ... 10, 1 ...
Ответы (1)