Задать вопрос
24 марта, 03:05

Необходимо составить программу с двумерным массивом. Для заполнения данного массива нужно использовать генератор случайных чисел.

I - отвечает за номер строки.

J - отвечает за номер столбца.

Заполненные массивы должны выглядеть так:

при const n=3

1 2 1

2 3 2

1 2 1

при const n=5

1 2 3 2 1

2 1 2 1 2

3 2 1 2 3

2 1 2 1 2

1 2 3 2 1

Желательно, составить блок-схему.

+2
Ответы (1)
  1. 24 марта, 03:14
    0
    В программе две константы: n и m. n отвечает за размер массива, m за максимальное значение случайного числа от 0 до на 1 меньше чем само m.

    Program Zadacha;

    Const n = 5; m = 5;

    Var a: Array [1 ... n, 1 ... n] of Integer;

    i, j: Integer;

    Begin

    Randomize;

    For i : = 1 To n Do

    For j : = 1 To n Do

    a[i, j] : = Random (m) ;

    WriteLn ('Результат:') ;

    For i : = 1 To n Do

    Begin

    For j : = 1 To n Do

    Write (a[i, j], ' ') ;

    WriteLn;

    End;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Необходимо составить программу с двумерным массивом. Для заполнения данного массива нужно использовать генератор случайных чисел. I - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Необходимо заполнить двумерный массив, как указано задании, в Pascal. I - отвечает за номер строки. J - отвечает за номер столбца.
Ответы (1)
1) Данное заполнение массива For i : = 1 to n do readln (a[ i ]) ; For i : = 1 to n do writeln (a[ i ]) ; производится Выберите один ответ: a. Через генератор случайных чисел b. По формуле c. С клавиатуры d.
Ответы (2)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)