Задать вопрос
16 апреля, 00:09

укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 25.

program B08;

var x, a, b: interger;

begin

readln (x) ;

a:=0; b:=0;

while x>0 do

begin

a:=a+1;

if (x mod 2) then

b: = b + (x mod 10) ;

x:=x div 10;

end;

writeln (a) ; write (b;

end.

+1
Ответы (1)
  1. 16 апреля, 02:05
    0
    Ответ: 997

    Программу правильно допиши:

    var x, a, b: integer;

    begin

    readln (x) ;

    a:=0; b:=0;

    while x>0 do

    begin

    a:=a+1;

    if (x mod 2) b then

    b: = b + (x mod 10) ;

    x:=x div 10;

    end;

    writeln (a) ; write (b) ;

    end.

    (исправленный вид)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 25. program B08; var x, a, b: interger; begin ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4. Var x, L, M: integer; begin readln (x) ; L:=0; M:=0; while x>0 do begin L:=L+1 If M< (x mod 5) then Begin M:=x mod 5 End X:=x div 5; End. Writeln (L) ; write (M) ; End
Ответы (1)
Uses crt; var n, s, s1, s2, k:integer; begin writeln ('Введите число: ') ; readln (n) ; s:=0; s1:=0; s2:=0; while n>0 do begin inc (k) ; if k mod 2 = 0 then begin s:=s+n mod 10; n:=n div 10; end else begin s1:=s1+n mod 10; n:=n div 10; end;
Ответы (1)
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
Умоляю, помогите ... Ниже на двух языках записан алгоритм. Получив на вход число x, этот алгоритм печатает два числа: a и b. Укажите наибольшее из таких четырёхзначных чисел x, при вводе которых алгоритм печатает сначала 7, а потом 29.
Ответы (1)