Задать вопрос
9 ноября, 18:22

Составьте программу на языке Паскаль: Найти сумму цифр трёхзначного числа.

+4
Ответы (1)
  1. 9 ноября, 21:03
    0
    Var a, a1, a2, a3, s;

    begin

    s:=0;

    readln (n) ;

    a1:=a div 100;

    a2: = a div 10 mod 10;

    a3:=a mod 10;

    s:=a1+a2+a3;

    write (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу на языке Паскаль: Найти сумму цифр трёхзначного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)